在线检测未来函数

注册免费送体验金平台

来源:Internet,编辑:股旁网,2012-03-30

编写要求:

股旁网解答:

 网友求助:

请老师根据资金流向指标写个预警公式,谢谢!!
要求:当副图出现----主力控盘系数为大于22,并小于33时出现预警(即主力控盘系数:22<?<33),谢谢!!(小弟不会写公式,不知道写不写得出来。)

{☆资金流向}
{//——————【参数定义】}
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{//——————【数值显示】}
散户套牢系数:INTPART(ZSHTL),LINETHICK0,COLORWHITE;
主力控盘系数:INTPART(ZZLKP),LINETHICK0,COLORCYAN;
资金流入强度:ZJLRQD,LINETHICK0,COLORRED;
市场筹码总量:INTPART(ZCMZL),LINETHICK0,COLORGREEN;
{//——————【图解模板】}
{神秘黑洞}
FILLRGN(REF(ZSHTL,1)>90 AND ZSHTL<90,ZSHTL,0),Color0080FF;
{散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,1,0),ColorC0C0C0;
{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),Color004080;
{散户线}
ZSHTL,LINETHICK0,COLORYELLOW;
{主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,7,0),COLORBLUE;
{铸顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,7,0),Color008080;
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,7,0),ColorFF00FF;
{筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,7,0),COLOR66FFCC;
{☆精确风险}
{//------【参数定义】}
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:=SMA(RSV,10,1);
D1:=SMA(K1,5,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;{//变异KD风险系数}
TGLD:=MOD(TFXXS,10);{//踏浪注册免费送体验金平台概率点}
TGLXS:=(TFXXS-REF(TFXXS,1))*10;{//变异KD乖离系数}
TYCFX:=TFXXS+TGLXS;{//变异KD预测风险}
{//------【数值显示】}
风险系数:TFXXS,LINETHICK0,COLORYELLOW;
乖离系数:TGLXS,LINETHICK0,COLORGREEN;
预测风险:TYCFX,LINETHICK0,COLORCYAN;
{//------【图解模板】}
{乖离系数}
STICKLINE(TGLXS>0,100,100+TGLXS,8,0),COLOR000088;
STICKLINE(TGLXS>0,100,100+TGLXS,7,0),COLOR000099;
STICKLINE(TGLXS>0,100,100+TGLXS,6,0),COLOR0000AA;
STICKLINE(TGLXS>0,100,100+TGLXS,5,0),COLOR0000BB;
STICKLINE(TGLXS>0,100,100+TGLXS,4,0),COLOR0000CC;
STICKLINE(TGLXS>0,100,100+TGLXS,3,0),COLOR0000DD;
STICKLINE(TGLXS>0,100,100+TGLXS,2,0),COLOR0000EE;
STICKLINE(TGLXS>0,100,100+TGLXS,1,0),COLOR0000FF;{//红柱}
STICKLINE(TGLXS<0,100,100+TGLXS,8,0),COLOR008800;
STICKLINE(TGLXS<0,100,100+TGLXS,7,0),COLOR009900;
STICKLINE(TGLXS<0,100,100+TGLXS,6,0),COLOR00AA00;
STICKLINE(TGLXS<0,100,100+TGLXS,5,0),COLOR00BB00;
STICKLINE(TGLXS<0,100,100+TGLXS,4,0),COLOR00CC00;
STICKLINE(TGLXS<0,100,100+TGLXS,3,0),COLOR00DD00;
STICKLINE(TGLXS<0,100,100+TGLXS,2,0),COLOR00EE00;
STICKLINE(TGLXS<0,100,100+TGLXS,1,0),COLOR00FF00;{//绿柱}
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,100,100+TGLXS,8,0),COLORRED;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,100,100+TGLXS,8,0),COLORGREEN;
{筹码总量}
PARTLINE(C>0,ZCMZL),COLORGREEN;
{筹码总量上升}
PARTLINE(ZCMZL>REF(ZCMZL,1),ZCMZL),COLOR0066FF;
{增量资金}
DRAWTEXT(ZCMZL>REF(ZCMZL,1) AND SH8<REF(SH8,1) AND BARSTATUS=2,ZCMZL,'↑\n增\n量\n资\n金'),Color00F9F9,align0;
{级别拐点}
VERTLINE(TGLXS>0 AND 100+TGLXS<TYCFX AND 100+REF(TGLXS,1)>=REF(TYCFX,1)),COLORYELLOW;
VERTLINE(TGLXS<0 AND 100+TGLXS>=TYCFX AND 100+REF(TGLXS,1)<REF(TYCFX,1)),ColorFF80FF;
{风险系数}
PARTLINE(TFXXS<160 AND TFXXS>50,TFXXS),LINETHICK2,Color0071E1;
PARTLINE(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1),TFXXS),LINETHICK2,COLORWHITE;
PARTLINE(TFXXS<=50,TFXXS),LINETHICK2,COLORYELLOW;
PARTLINE(TFXXS>=160,TFXXS),LINETHICK2,COLORBLUE;
{预测风险}
PARTLINE(C>0,TYCFX),COLORCYAN;
{//------【解盘分析】}
TJTS:=SYSPARAM(1);
EXPLAIN(TJTS and C>0,' '+STKLABEL+' '+STKNAME+' '),Color1E67FF;
EXPLAIN(TJTS and C>0,'走牛天数判断:'+' '+NUMTOSTR( ZZNTS,0 ))ColorFFFF80;
{主力动向监控}
EXPLAIN(TJTS and ZCMZL>REF(ZCMZL,1) AND DKB=1,'主力动向监控:主力增仓'),COLORRED;
EXPLAIN(TJTS and ZCMZL>REF(ZCMZL,1) AND DKB=0,'主力动向监控:主力减仓 '),COLORMAGENTA;
EXPLAIN(TJTS and ZCMZL=REF(ZCMZL,1),'主力动向监控:多空平衡 '),COLORGRAY;
EXPLAIN(TJTS and ZCMZL<REF(ZCMZL,1) AND DKB=1,'主力动向监控:主力回补'),COLORFF9933;
EXPLAIN(TJTS and ZCMZL<REF(ZCMZL,1) AND DKB=0,'主力动向监控:主力出逃'),COLORGREEN;
{特别信号提示}
EXPLAIN(TJTS and ZSHTL>90,'特别信号提示:筑底散兵坑 '),COLOR66FFCC;
EXPLAIN(TJTS and ZZLKP>75,'特别信号提示:铸顶风险区 '),COLORCYAN;
EXPLAIN(TJTS and CROSS(ZCMZL,ZZLJJ) AND ZZLKP>ZZLJJ AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1),'特别信号提示:穿越主力 '),COLORRED;
EXPLAIN(TJTS and CROSS(ZCMZL,ZZLKP) AND ZZLKP>ZZLJJ AND ZZLKP<ZSHTL AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1),'特别信号提示:穿越主力'),COLORYELLOW;
EXPLAIN(TJTS and CROSS(ZCMZL,ZSHTL) AND ZSHTL>ZZLKP AND ZCMZL>REF(ZCMZL,1),'特别信号提示:穿越散户'),COLORGREEN;
EXPLAIN(TJTS and CROSS(ZCMZL,100) AND ZCMZL>REF(ZCMZL,1),'特别信号提示:全盘穿越 '),COLOR3399FF;
EXPLAIN(TJTS and REF(ZSHTL,1)>90 AND ZSHTL<90,'特别信号提示:神秘黑洞 '),COLOR9966FF;
EXPLAIN(TJTS and TFXXS<=50,'操作风险提示:买入风险'),COLORYELLOW;
EXPLAIN(TJTS and TFXXS>=160,'操作风险提示:卖出风险'),COLORCYAN;
EXPLAIN(TJTS and TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS<=100,'操作风险提示:追涨博弈'),COLORRED;
EXPLAIN(TJTS and TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS>100,'操作风险提示:稳健持股'),COLORMAGENTA;
EXPLAIN(TJTS and TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS>100,'操作风险提示:盘跌减仓'),COLORWHITE;
EXPLAIN(TJTS and TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS<=100,'操作风险提示:杀跌空仓'),COLORGREEN;
 

 
解答如下:
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
主力控盘系数:=INTPART(ZZLKP),LINETHICK0,COLORCYAN;

主力控盘系数>22 and 主力控盘系数<33;

 

相关文章