在线检测未来函数

注册免费送体验金平台

来源:Internet,编辑:股旁网,2012-10-28

编写要求:

要求: 1.看看有无未来函数(出来的信号会不会漂移)。 2.如果没有未来 请将“底”做个选股预警. 源码如下: 牛熊线:=0; A:=EMA(CLOSE,13); LC:=REF(CLOSE,1); RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; AR:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100; 卖点雷达:CROSS(85,RSI1)*30; DRAWTEXT(CROSS(85,RSI1),80,'顶'); VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100; VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100; VARD:=BARSCOUNT(CLOSE); 买点雷达:(VARB< 20 AND VARC< 25 AND VARD> 50 AND AR<70 AND VOLREF(散户,1) OR CROSS(主力,散户) AND 散户<-35 ,-15,1); DRAWTEXT(CROSS(RSI1,20)AND 散户<-20 AND 买点雷达 ,-60,'底');

股旁网解答:

 LC:=REF(CLOSE,1);
AR:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARD:=BARSCOUNT(CLOSE);
买点雷达:=(VARB< 20 AND VARC< 25 AND VARD> 50 AND AR<70 AND VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)<REF(VOL,3))*30;
散户:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
CROSS(RSI1,25) OR (CROSS(RSI1,20)AND 散户<-20 AND 买点雷达);

相关文章